Serial Monitor

This window can be used in order to read/write data from/to available serial ports. It can be opened by selecting the Serial Monitor... command from the View menu.

Figure 5-144. The Serial Monitor Window

The actions in the tool bar provide quick access to the main operations that can be performed on a serial port. These actions can be also triggered via the four menus available for this window: File, Edit, Data and Help.

The actions available in the File menu are:

New -> Table (Ctrl-T)

Creates a new table from the data available in the monitor window, using the default ASCII import settings. Closes the connection to the serial port.

New -> Graph (Ctrl-G)

Creates a new hidden table from the data available in the monitor window, using the default ASCII import settings and plots the imported data columns into a new plot window using the default user settings for new 2D graphs. Closes the connection to the serial port.

Save (Ctrl-S)

Opens a file save dialog allowing to choose the path where to save the data available in the monitor window. The connection to the serial port is closed.

Import ASCII... (Ctrl-K)

Opens the ASCII import dialog allowing to define the default import settings for the data available in the monitor window. The serial port is closed and the data available in the monitor window is saved to a temporary .txt file, the name and path of this file being displayed in the dialog.

Quit

Closes this window.

The actions available in the Edit menu are:

Preferences...

Opens the Serial Port Settings dialog allowing to select the name of an available serial port and its parameters.

Copy (Ctrl-C)

Copies the text from the monitor window into the clipboard.

Clear

Clears the text available in the monitor window.

The actions available in the Data menu are:

Connect (Ctrl+R)

Tries to open a connection to the serial port using the parameters specified in the Serial Port Settings dialog. Once the connection is established, the information about the name of the current serial port and the parameters used for the connection is displayed in the status bar of this window.

Disconnect

Closes the connection with the serial port.

The Help menu contains a single action, Help, that can be used in order to open the quick help panel and to display this chapter from the user manual.